1. Con una cuenta podrás:

    • Publicar preguntas y pedir ayuda
    • Crear tutoriales
    • Acceder a contenido privado
    • Convertirte en un Héroe de la web
    Cerrar notificación
  2. Eres nuevo en la comunidad y necesitas ayuda?
    Sigue estos pasos y recomendaciones antes de publicar tu duda:
    Cerrar notificación

Wordpress sirviendo Django

Tema en 'Alojamiento Web, Servidores y Dominios' comenzado por ChicoMTZ, 14 de Junio de 2016.

  1. ChicoMTZ

    ChicoMTZ Nuevo Miembro

    Se incorporó:
    5 de Abril de 2016
    Mensajes:
    15
    Me gusta recibidos:
    0
    Puntos de trofeos:
    1
    Género:
    Hombre
    Ocupación:
    Webmaster
    Localización:
    Cuba
    Página web:
    Hola a todos tengo un problem con algo que quiero hacer. Tengo una pagina en wordpress: ejemplo.com En wordpress y necesito que ejemplo.com/servicios sea de Django, o sea, otro sitio, ya he modificado la config del archivo de Wordpress pero nada aun y no sé cual es el problema, me sale el sitio de Wordpress correctamente pero el de Django me sale como una carpeta. Creo que el problem debe ser que el módulo Wsgi no reconoce mi sitio con la cofig tal y como la tengo. Utilizo Debian 7 y Apache 2.2. Mi config es la siguiente:

    WSGIPythonPath /var/www/servicios

    <VirtualHost *:80>

    #----------------------Django------------------------------

    WSGIScriptAlias /servicios /var/www/servicios/untitled1/wsgi.py$1
    Alias /servicios /var/www/servicios
    Alias /static/ /var/www/servicios/Servicios/static/
    Alias /media/ /var/www/servicios/Servicios/media/

    #App de Django
    <Directory /var/www/servicios/untitled1>
    <Files wsgi.py>
    Order deny,allow
    Allow from all
    </Files>
    </Directory>

    #Carpeta para los archivos Css
    <Directory /var/www/servicios/Servicios/static>
    Order deny,allow
    Allow from all
    </Directory>

    #Carpeta para los archivos media
    <Directory /var/www/servicios/Servicios/media>
    Order deny,allow
    Allow from all
    </Directory>

    #--------Wordpress php-------------

    Alias / /var/www/hosproma/
    ServerAdmin webmaster@localhost
    ServerName hpm.mtz.sld.cu
    AddType application/x-httpd-php .php
    ServerAlias hpm.mtz.sld.cu

    #Sitio en Wordpress
    DocumentRoot /var/www/hosproma
    <Directory /var/www/hosproma>
    Options FollowSymLinks
    </Directory>

    #Sitio creado en Php, ok
    <Directory /var/www/hosproma/directorio/>
    Order allow,deny
    allow from all
    </Directory>


    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>
    ErrorLog ${APACHE_LOG_DIR}/error.log

    LogLevel warn

    CustomLog ${APACHE_LOG_DIR}/access.log combined

    ErrorLog ${APACHE_LOG_DIR}/pyerror.log
    CustomLog ${APACHE_LOG_DIR}/pyaccess.log combined


    </VirtualHost>
     

Comparte esta página